峰哥分时起爆通达信分时副图指标公式(源码不加密、无未来不漂移)

更新时间:2020-04-24 18:04:58    浏览:31

峰哥分时起爆通达信分时副图指标公式(源码不加密、无未来不漂移)


DRAWGBK(C>0, RGB(0,10,10),RGB(88,0,0),0,'11',0);

NN:=2400;

HD:=HHV(V,NN);

LD:=LLV(V,NN);

最高:=CONST(HD),NODRAW;

最低:=CONST(LD),NODRAW;

HLMAX:=最高;

HLMIN:=最低;

HLMN1:=(HLMAX+HLMIN)/2;

HLMN2:=HLMAX-HLMIN;

HLMN3:=(100-0)/2*1.3;

HLMN4:=(100-0)/1*1.3;

中间价轴:=(50-HLMN3)*HLMN2/HLMN4+HLMN1;

轴差:=最高-最低;

拉升量:=IF(C>REF(C,1),VOL,0);

打压量:=IF(C<REF(C,1),VOL,0);

昨拉升最高值:CONST(FINDHIGH(拉升量,FROMOPEN,240,1)),LINETHICK1,COLORMAGENTA;

昨打压最高值:=CONST(FINDHIGH(打压量,FROMOPEN,240,1)),LINETHICK1,COLORCYAN,NODRAW;

今拉升最高值:=CONST(REF(HHV(拉升量,FROMOPEN),0)),COLORRED;

今打压最高值:CONST(REF(HHV(打压量,FROMOPEN),0)),COLORCYAN,NODRAW;

攻击力度:今拉升最高值/昨拉升最高值,NODRAW;

量能均线:=SUM(V,FROMOPEN)/FROMOPEN;

量:=VOL,VOLSTICK;

五日量:=MA(量,5),COLORWHITE;

TT:=BARSCOUNT(C);{取得有效收盘价}

均价黄:=SUM(C*V,TT)/SUM(V,TT);{分时均线的取值}

量两步:=MA(V,5)>REF(MA(V,5),1) AND REF(MA(V,5),1)>REF(MA(V,5),2);

价两步:= C>=REF(C,1) AND REF(C,1)>REF(C,2);

价上岗量破5:=C>均价黄 AND V>MA(V,5);

量起爆:=V>=REF(V,1)*1;

价创新高:=C>=HHV(C,0);

量创新高:=V>=HHV(V,0);

对昨日涨幅:=(C/DYNAINFO(3)-1)*100<=2.50;{涨幅控制2个点以内}

每日一点:=量两步 AND 价两步 AND 价上岗量破5 AND 量起爆 AND 价创新高 AND 量创新高 AND 对昨日涨幅;

{计算收益、已爆分钟}

VV:=BARSSINCE(每日一点)+1;

首次起爆价:=REF(C,VV-1),NODRAW;

起爆收益:(DYNAINFO(7)-首次起爆价)/首次起爆价*100,NODRAW;

流通盘:=CAPITAL*100/100000000,NODRAW;

起爆时间:=REF(TIME/10000,VV),NODRAW;

已爆分钟:=VV-1,NODRAW;

STICKLINE(C>REF(C,1) AND V>=今打压最高值,0,V,0,0),COLORRED;

STICKLINE(C<REF(C,1) AND V>=今拉升最高值,0,V,0,0),COLORGREEN;

DRAWICON(C<REF(C,1) AND V>=今拉升最高值,V,2);

{100股票学习网 WWW.100151.COM}

STICKLINE(C>REF(C,1) AND (V>昨拉升最高值 OR V>昨打压最高值),0,V,0,0),COLOR0000FF;

STICKLINE(C>REF(C,1) AND V>=2*昨拉升最高值 AND V<5*昨拉升最高值,昨拉升最高值,V,0,0),COLORFF00FF;

STICKLINE(C>REF(C,1) AND V>=5*昨拉升最高值,0,V,0,0),COLORMAGENTA;

STICKLINE(每日一点,最低+轴差*0.8,0,1,0),COLORMAGENTA;

DRAWICON(每日一点,V,1),COLORRED;

DRAWTEXT(每日一点,最低+轴差*0.8,'∠起爆'),COLORMAGENTA;

TA:=BARSLAST(TIME=100000);

TC:=REF(HHV(C,0),TA+1);

TV:=REF(HHV(V,0),TA+1);

ZF:=TC/DYNAINFO(3)<1.05;

XG1:=CROSS(C,TC) AND V>TV AND ZF,COLORWHITE;

TA1:=BARSLAST(TIME=110000);

CC1:=REF(HHV(C,0),TA1+1);

VV1:=REF(HHV(V,0),TA1+1);

ZF1:=CC1/DYNAINFO(3)<1.05;

XG2:=CROSS(C,CC1) AND V>VV1 AND ZF1,COLORYELLOW;

突破:=XG1 OR XG2,COLORRED;

VT:=BARSSINCE(突破)+1;

首次突破价:=REF(C,VT-1),NODRAW;

突破收益:(DYNAINFO(7)-首次突破价)/首次突破价*100,NODRAW;

STICKLINE(突破,V,0,1,0),COLORRED;

DRAWICON(突破=1,V,17);

DRAWTEXT(突破=1,最低+轴差*0.65,'☆突破'),COLORRED;

DRAWICON(FILTER(CROSS(拉升量,昨拉升最高值),30),V,1);

DRAWTEXT(FILTER(CROSS(拉升量,昨拉升最高值),30),最低+轴差*0.50,'★攻击'),COLORYELLOW;

DRAWICON(FILTER(CROSS(拉升量,今打压最高值),30),V,1);

DRAWTEXT(FILTER(CROSS(拉升量,今打压最高值),30),最低+轴差*0.35,'★攻击'),COLORMAGENTA;

大单买:SUM(IF(C>REF(C,1) AND V>4000,V/5,0),0),COLORRED,LINETHICK3;

大单卖:SUM(IF(C<REF(C,1) AND V>4000,V/5,0),0),COLORGREEN,LINETHICK3;

买单总:=SUM(IF(C>REF(C,1),V/5,0),0);

卖单总:=SUM(IF(C<REF(C,1),V/5,0),0);

小单买:买单总-大单买,COLORLIRED,DOTLINE;

小单卖:卖单总-大单卖,COLORLIBLUE,DOTLINE;

量极值:=CONST(VOL);

大单买量:=SUM(IF(C>REF(C,1) AND V>4000,V/1000,0),0),NODRAW;

大单卖量:=SUM(IF(C<REF(C,1) AND V>4000,V/1000,0),0),NODRAW;

买单总量:=SUM(IF(C>REF(C,1),V/1000,0),0),NODRAW;

卖单总量:=SUM(IF(C<REF(C,1),V/1000,0),0),NODRAW;

小单买量:=买单总量-大单买量,NODRAW;

小单卖量:=卖单总量-大单卖量,NODRAW;

大宗进:=大单买量,NODRAW;

大宗出:=大单卖量,NODRAW;

非大宗进:=小单买量,NODRAW;

非大宗出:=小单卖量,NODRAW;

主力净流入:=大单买量-大单卖量,COLORRED,NODRAW;

散户净流入:=小单买量-小单卖量,COLORRED,NODRAW;

净流入:=买单总量-卖单总量,COLORRED,NODRAW;

均价:=SUM(V*C,0)/SUM(V,0),COLORYELLOW;

DRAWTEXT_FIX(1,0.000,0.00,0,STRCAT(STRCAT('主力 ',CON2STR(主力净流入,0)),'万')),COLORMAGENTA;

DRAWTEXT_FIX(1,0.000,0.2,0,STRCAT(STRCAT('散户 ',CON2STR(散户净流入,0)),'万')),COLORCYAN;

DRAWTEXT_FIX(1,0.125,0.00,0,STRCAT(STRCAT('净流入 ',CON2STR(净流入,0)),'万')),COLORYELLOW;

地:=EMA(均价,50)/0.97,LINETHICK2,COLORGREEN;

买单次数:=COUNT(V>4000 AND C>REF(C,1),0);

黄次数:=COUNT(V>DYNAINFO(16)*10 AND C>REF(C,1),0),COLORYELLOW,NODRAW;

DRAWICON(买单次数>REF(买单次数,1) AND 黄次数>REF(黄次数,1) AND CROSS(C,地),大单买,7);

DRAWICON(小单买量>小单卖量 AND 大单买量>小单买量 AND 小单卖量>大单卖量,大单买,41);

BGTYU:=IF(DATE>=1130107,1,0);

GHYJKU:=BETWEEN((DCLOSE*BGTYU)/(SUM(AMOUNT,BARSCOUNT((DCLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*BGTYU)))),1.05,0.95);

VBNH:=IF(GHYJKU=0,MA((DCLOSE*BGTYU),BARSCOUNT((DCLOSE*BGTYU))),(SUM(AMOUNT,BARSCOUNT((DCLOSE*BGTYU)))/SUM(VOL*100,BARSCOUNT((DCLOSE*BGTYU)))));

DRAWTEXT(CROSS(EXPMA((DCLOSE/VBNH),120),1.0029),小单买,'↖可买'),COLORWHITE;

DRAWICON(CROSS(EXPMA((DCLOSE/VBNH),120),1.0029),小单买,25);

DRAWTEXT(CROSS(EXPMA((DCLOSE/VBNH),120),1.004),小单卖,'↖转强'),COLORMAGENTA;

DRAWICON(CROSS(EXPMA((DCLOSE/VBNH),120),1.004),小单卖,13);

DRAWICON(CROSS(EXPMA((DCLOSE/VBNH),20),1.02),小单买,1);

吃定:=(EXPMA(CLOSE,500)-REF(EXPMA(CLOSE,500),1))/REF(EXPMA(CLOSE,500),1)*100, COLORSTICK;

主力:=EXPMA( (EXPMA(CLOSE,500)-REF(EXPMA(CLOSE,500),1))/REF(EXPMA(CLOSE,500),1)*100,120)-0.0004,LINETHICK5,COLORMAGENTA;

散户:=EXPMA( (EXPMA(CLOSE,500)-REF(EXPMA(CLOSE,500),1))/REF(EXPMA(CLOSE,500),1)*100,200),LINETHICK5,COLORGREEN;

DRAWICON(CROSS(EXPMA(吃定,120)-0.0004,EXPMA(吃定,200)),小单买,13); 

DRAWTEXT(CROSS(EXPMA(吃定,120)-0.0004,EXPMA(吃定,200)),小单买,'↖金叉'),COLORRED;

DRAWICON(CROSS(EXPMA(吃定,120)-0.0004,EXPMA(吃定,200)),小单买,13); 

Q:=BETWEEN(C/(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))),1.05,0.95);

Q2:=IF(Q=0,MA(C,BARSCOUNT(C)),(SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C))));

STICKLINE(CROSS((C/Q2),1.03),1.01,1.02,1.0,0), , COLORYELLOW;

DRAWICON(CROSS((C/Q2),1.03),小单买,1);


本类最热门下载
你可能会感兴趣的内容

声明:100股票学习网提供的《峰哥分时起爆通达信分时副图指标公式(源码不加密、无未来不漂移)》是供您免费下载,如有站内广告收费行为,均与本站无任何关系!请网友小心谨慎。
Powered By 100股票学习网 www.100151.com © 2014-2020
赣ICP备20004582号
赣公网安备 36072202000169号